Below are the specs we require you to have in order to run Looop.

Browser

IE11 and up.

Chrome, Firefox and Safari 10 and up.

Mobile and devices

iOS 10+ and up.

Android 4.1+ and up.

Did this answer your question?